Cant connect virtualHost to VMWareWorkstation

Jul 19, 2012 at 6:35 AM
Edited Jul 19, 2012 at 7:24 AM

Hey everybody,

I have a VMWorkstation (7.1.6) on Windows 7 (64 bit) system, VMWareTask-1.6 and want to clone a machine.

At connectToVMWareWorkstation a exception was thrown. Has anyone the same problem? 

Thank you!

-ehmkey

VMWareVirtualHost virtualHost = new VMWareVirtualHost();
virtualHost.ConnectToVMWareWorkstation();
Failed to connect: serviceProviderType="Workstation" hostName="" hostPort=0 username="" timeout=60
at Vestris.VMWareLib.VMWareVirtualHost.Connect(ServiceProviderType serviceProviderType, String hostName, Int32 hostPort, String username, String password, Int32 timeout)   
at Vestris.VMWareLib.VMWareVirtualHost.ConnectToVMWareWorkstation(Int32 timeoutInSeconds)   
at Vestris.VMWareLib.VMWareVirtualHost.ConnectToVMWareWorkstation()
Jul 19, 2012 at 9:12 AM

I forgot to post the inner exception. What does it mean with "the specified version was not found" ?

 

InnerException: Vestris.VMWareLib.VMWareException
       Message=The specified version was not found
       Source=Vestris.VMWareLib
       ErrorCode=22002
       StackTrace:
            at Vestris.VMWareLib.VMWareInterop.Check(UInt64 errCode)
            at Vestris.VMWareLib.VMWareJob..ctor(IJob job, VMWareJobCallback callback)
            at Vestris.VMWareLib.VMWareVirtualHost.Connect(ServiceProviderType serviceProviderType, String hostName, Int32 hostPort, String username, String password, Int32 timeout)
       InnerException: 

Coordinator
Jul 19, 2012 at 11:05 AM

This project has moved to Github. Please post questions to https://groups.google.com/forum/?fromgroups#!forum/vmwaretasks