Intermittant exception when requiring interactive login

Jun 26, 2010 at 1:30 PM

Hello,

 I'm having an intermittant issue with our VM's using the LogInGuest and the VIX_LOGIN_IN_GUEST_REQUIRE_INTERACTIVE_ENVIRONMENT flag.

 I am using remote desktop to log into our Xp SP3 VM as a domain user and see that the VMWareUser.exe is running as that user. However, sometimes I get into a situation where I continually throw the following exception:

The specified guest user must be logged in interactively to perform this operation

   at Vestris.VMWareLib.VMWareInterop.Check(UInt64 errCode)
   at Vestris.VMWareLib.VMWareJob.Wait(Int32 timeoutInSeconds)
   at Vestris.VMWareLib.VMWareVirtualMachine.LoginInGuest(String username, String password, Int32 options, Int32 timeoutInSeconds)
   at VMWareConfiguration.VirtualMachineServer.DoVMWareTasks() in C:\work\Automated Testing\AutomateInstallation\Sandbox\VmProjects\ConsoleApplication2\ConsoleApplication2\VirtualMachineServer.cs:line 720

 

 I am able to do a regular login without the require flag.

Normally a reboot on my dev station cleared the issue. Another time I removed the vm from the domain and put it back on the domain and that seemed to work however there seems to be a fundamental issue at play here that I don't fully understand.

Any suggestions on how to troubleshoot this problem? Are there com interop logs/config's I could be looking for?

Thanks for your help! 

 

Coordinator
Jun 26, 2010 at 1:32 PM

I doubt that the wrapper has anything to do with the problem, I would ask the VixCOM forum.

Jun 26, 2010 at 1:56 PM

Thanks for the quick respone. I just posted the question in the other forum and if I get the right answer I'll update this thread.

Developer
Feb 16, 2011 at 4:52 AM

I've created a work item here:

http://vmwaretasks.codeplex.com/workitem/8352

I've also uploaded patch #8386 for this issue.