"The specified version was not found" at trying to connect ESXi 4.0

Apr 13, 2010 at 3:29 PM
Edited Apr 13, 2010 at 3:30 PM

It seems the API changed somehow for the 4.0 version.

I get the exception when executing the code which should connect to ESXi 4.0

 

using (VMWareVirtualHost virtualHost = new VMWareVirtualHost())
{
                // connect to a remove (VMWare ESX) virtual machine
                virtualHost.ConnectToVMWareVIServer("https://172.26.240.71/", "root", "");

}

 

Coordinator
Apr 13, 2010 at 8:25 PM

First, use "172.26.240.71" without the HTTPs. If the same error persists after that, you probably just don't have the right version of VixCOM. Get 1.8.1.

Apr 14, 2010 at 9:50 AM

Thanks! It works.